1. Dismiss Notice
  2. Picture Of The Week (POW) Information and Submissions
    CLICK HERE!
    (if you are logged in, this notice can be dismissed using the "x" to the top right of the notice)

    Dismiss Notice
  3. Official PK Poll: Is there any future in refilling?
    CLICK HERE!
    (if you are logged in, this notice can be dismissed using the "x" to the top right of the notice)

    Dismiss Notice
  4. PK Featured Thread: The Epson RPM quality option - does it offer a benefit ?
    CLICK HERE!
    (if you are logged in, this notice can be dismissed using the "x" to the top right of the notice)

    Dismiss Notice

Pixma IP8750 - WIFI connection Issues

Discussion in 'Canon InkJet Printers' started by PeterG, Oct 28, 2018.

  1. Oct 28, 2018
    PeterG

    PeterG Printing Apprentice

    Joined:
    Oct 7, 2018
    Messages:
    10
    Likes Received:
    5
    Trophy Points:
    15
    Printer Model:
    Prixma Pro 1
    Hi all,

    We've recently purchased a Pixma IP8750. It's a great printer and prints well, but we've only been using it over the USB connection. However it has now become essential to print via an iPAD to the printer and to do this it needs to be connected to the wifi. No biggie as it's all speced for that but here's were it falls down, no matter what I do I can't get it to 'take' an IP address. It appears to connect to the network but when you do a network details print, i.e. hold the reset button down until the amber light flashes 6 times, there is no ip address on the print. When you 'show network details' from the software an IP address is present but it's as if it's not being uploaded to the printer.
    I've had a look about on the net about this and have tried removing N from the WiFi as that may help, the only other thing would be to disable IPv6 but I can't find where you'd do that from.

    Any thoughts from you guys as this is beginning to get frustrating. It's as if Canon have half a really good product and have just thrown it out to the public.

    I've tried WPS but again all this does is connect to the network, it doesn't show an IP and you can't see it in the net.

    Answers on a postcard.....
    Thanks
    Peter.
     
    The Hat likes this.
  2. Oct 28, 2018
    stratman

    stratman Printer VIP Platinum Printer Member

    Joined:
    Apr 19, 2007
    Messages:
    5,534
    Likes Received:
    3,680
    Trophy Points:
    373
    Location:
    USA
    Printer Model:
    Canon MP830, Pencil
    Canon printers can be finicky on the order you install everything. From the this link, section #13, if at first you do not succeed, try again from scratch. Uninstall everything for the printer, reboot, and then reinstall as if you just took it out the box brand new. Follow all installation instructions exactly.

    Wifi Installation.jpg
     
  3. Oct 28, 2018
    PeterG

    PeterG Printing Apprentice

    Joined:
    Oct 7, 2018
    Messages:
    10
    Likes Received:
    5
    Trophy Points:
    15
    Printer Model:
    Prixma Pro 1
    OK, I've done a little more investigation and it appears that the 8750 doesn't like WPA2 and AES for the WiFi security. If you change it to TKIP the Canon works. GREAT... not so much because then the Brother won't connect as WPA2 and TKIP isn't supported by that and teh Epson has given up as you have to turn WPS off if you don't have WPA2 and AES enabled on the router..!!!!!!

    The fun continues.....
     
  4. Oct 28, 2018
    stratman

    stratman Printer VIP Platinum Printer Member

    Joined:
    Apr 19, 2007
    Messages:
    5,534
    Likes Received:
    3,680
    Trophy Points:
    373
    Location:
    USA
    Printer Model:
    Canon MP830, Pencil
    I wouldn't like having to use TKIP either but if you have some older wireless devices that cannot do AES then you are stuck.

    Like an Irishman I know who is fond of saying... Feck WPS. Set up wireless the tried and true way using the Canon Ij Network tool that is installed when first setting up the printer. For this you will need to have the printer connected via USB cable to the computer you are using to install the printer. Follow all directions explicitly.

    (To be honest, the Irishman I know doesn't do wireless but he does like saying Feck)

    Canon usually has adequate instruction. See this online User Manual with attention to the Ij Network Tool starting on page 143.

    Know the SSID of your access point (usually your wireless router), and its network key / password. These are typically found on a label on the wireless router. Hopefully, your printer will see your access point during the installation setup and allow you to select it and then you input the password / key followed by he security type. You want WPA2 with AES if possible. Whatever security protocol your access point and wireless devices have is what you are limited to.
     
    The Hat likes this.
  5. Oct 28, 2018
    stratman

    stratman Printer VIP Platinum Printer Member

    Joined:
    Apr 19, 2007
    Messages:
    5,534
    Likes Received:
    3,680
    Trophy Points:
    373
    Location:
    USA
    Printer Model:
    Canon MP830, Pencil
    If you are concerned about security having to use TKIP with the printer, then see if you can connect the printer to your wireless router via a USB cable and turn off the wireless function on the printer. If your wireless router can act as a wireless print server then it will shield inquiring minds from hacking your network via a weakly secured wireless printer.
     
    The Hat likes this.
  6. Oct 29, 2018
    PeterG

    PeterG Printing Apprentice

    Joined:
    Oct 7, 2018
    Messages:
    10
    Likes Received:
    5
    Trophy Points:
    15
    Printer Model:
    Prixma Pro 1
    OK, It may be easier to understand if I word this differently...
    I have a wireless network in a workshop, large room with lots of things in, wires are a trip hazard and best off not being used, hence the want for wireless printing. I also have a requirement for printing from iPad design software.
    In this environment I have three printers, a Brother colour laser, an Epson 1500W and a Canon ip8750.
    The Brother laser is a general purpose printer mainly used to generate invoices and draft prints
    The Epson is for A3+ sublimation printing so has specialist inks
    The Canon is for posters and leaflet printing, so has standard ink jet inks
    I have a single wireless access point for this room, the security is set to WPA2-AES.

    The Brother is manually setup on WiFi using the screen and keys and attaches ok, all works well and you can print from the MAC and iPAD with no issues
    The Epson doesn't have a screen so the only way I've managed to get this to connect is using WPS, which has connected it without issue and you can print to it from the MAC
    The Canon is a different story...

    No matter how you do it, WPS or the Canon printer setup utility from either the MAC or a Windows 10 PC, if the security of the network remains at WPA2-AES the printer doesn't take an IP address. It will attach to the WiFi network, so the SSD and key are correct, but, when you print the network info page, there is nothing in the IPv4 or IPv6 sections. I've trolled around the internet for a bit and I can find other people having this issue and not being able to get it resolved, having to take their printer back for a refund.. Is this the only thing open to me??? I've not found anything to say that the Canon doesn't support WPA2-AES and I'm interested to see if other owners of this printer out there have similar issues or is it just a select few of us??
    The ONLY way I've managed to get the Canon to take an IP address, and print it on the network information sheet, is to change the WiFi security setting on the access point. However this then disrupts the connections I have with the other printers.

    So in summary;
    I've tried all ways to configure the printer.
    I can't use a USB cable in general operation.
    I need the Canon WiFi enable printer to connect to a WiFi network that two other companies printers are very happy to connect to, without changing the setup of that network.
     
  7. Oct 29, 2018
    PeterG

    PeterG Printing Apprentice

    Joined:
    Oct 7, 2018
    Messages:
    10
    Likes Received:
    5
    Trophy Points:
    15
    Printer Model:
    Prixma Pro 1
    I've fixed it.!!!!
    In the end, while clutching at straws, I setup a DHCP scope on the access point the printer attached to and hey presto it got it's IP address and now works.
    You shouldn't need to do this as the IP address should be allocated via the master scope on my main router but hey, this works and I'm happy now..!!!!

    Thanks for your time.
     
    stratman and The Hat like this.
  8. Oct 29, 2018
    The Hat

    The Hat Printer VIP Moderator

    Joined:
    Jan 18, 2010
    Messages:
    10,889
    Likes Received:
    4,848
    Trophy Points:
    393
    Location:
    Wicklow Ireland
    Printer Model:
    Canon were, BUT 3D is better..
    @PeterG, Thank you for the feedback on your great success, and @stratman will be pleased, that’s one of the reasons why I don’t use Wi-Fi because it can all be in the Feckin clouds...

    Wires are Superior every time..;)
     
  9. Oct 29, 2018
    stratman

    stratman Printer VIP Platinum Printer Member

    Joined:
    Apr 19, 2007
    Messages:
    5,534
    Likes Received:
    3,680
    Trophy Points:
    373
    Location:
    USA
    Printer Model:
    Canon MP830, Pencil
    More than one router? Which is your default gateway? Are you using a wireless router bridge? Are you using dynamic or static addressing with your DHCP before or now? How many devices were allowed by the setting in your Subnet Mask?? It seems your set up may be a little more complicated than you let on and may not have been the fault of the printer at all.

    The most important thing is that it is working. Congratulations on your success! :clap
     
    The Hat likes this.

Share This Page